libquvi-scripts-0.9.20131130.ebuild 625 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Embedded lua scripts for libquvi"
  5. HOMEPAGE="http://quvi.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/quvi/${P}.tar.xz"
  7. LICENSE="AGPL-3"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~arm ~hppa ~mips x86"
  10. IUSE="offensive"
  11. RDEPEND=">=dev-lua/LuaBitOp-1.0.1
  12. >=dev-lua/luaexpat-1.2.0
  13. >=dev-lua/luajson-1.1.1
  14. >=dev-lua/luasocket-2.0.2"
  15. DEPEND="app-arch/xz-utils
  16. virtual/pkgconfig"
  17. # tests fetch data from live websites
  18. RESTRICT="test"
  19. src_configure() {
  20. econf \
  21. $(use_with offensive nsfw) \
  22. --with-manual
  23. }