libvisio-0.1.5.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
  5. inherit autotools
  6. [[ ${PV} == 9999 ]] && inherit git-r3
  7. DESCRIPTION="Library parsing the visio documents"
  8. HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
  9. [[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
  10. LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
  11. SLOT="0"
  12. [[ ${PV} == 9999 ]] || \
  13. KEYWORDS="amd64 ~arm hppa ppc64 x86"
  14. IUSE="doc static-libs test tools"
  15. RDEPEND="
  16. dev-libs/icu:=
  17. dev-libs/librevenge
  18. dev-libs/libxml2
  19. sys-libs/zlib
  20. "
  21. DEPEND="${RDEPEND}
  22. dev-lang/perl
  23. dev-libs/boost
  24. dev-util/gperf
  25. sys-devel/libtool
  26. virtual/pkgconfig
  27. doc? ( app-doc/doxygen )
  28. test? ( dev-util/cppunit )
  29. "
  30. PATCHES=( "${FILESDIR}/${PN}-0.1.3-tests-without-tools.patch" )
  31. src_prepare() {
  32. default
  33. [[ -d m4 ]] || mkdir "m4"
  34. eautoreconf
  35. }
  36. src_configure() {
  37. econf \
  38. --disable-werror \
  39. $(use_with doc docs) \
  40. $(use_enable static-libs static) \
  41. $(use_enable test tests) \
  42. $(use_enable tools)
  43. }
  44. src_install() {
  45. default
  46. find "${D}" -name '*.la' -delete || die
  47. }