libxspf-1.2.0.ebuild 1011 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. DESCRIPTION="Playlist handling library"
  6. HOMEPAGE="http://libspiff.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/libspiff/${P}.tar.bz2"
  8. LICENSE="BSD LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
  11. IUSE="doc static-libs test"
  12. RDEPEND=">=dev-libs/expat-2
  13. >=dev-libs/uriparser-0.7.5"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig
  16. doc? (
  17. >=app-doc/doxygen-1.5.8
  18. media-gfx/graphviz
  19. dev-qt/qthelp:4
  20. )
  21. test? ( >=dev-util/cpptest-1.1 )"
  22. DOCS="AUTHORS ChangeLog NEWS README THANKS"
  23. src_prepare() {
  24. epatch \
  25. "${FILESDIR}"/${P}-gcc44.patch \
  26. "${FILESDIR}"/${P}-gcc47.patch
  27. }
  28. src_configure() {
  29. export XDG_CONFIG_HOME="${T}" #398881#c2
  30. econf \
  31. --docdir="${EPREFIX}"/usr/share/doc/${PF} \
  32. $(use_enable static-libs static) \
  33. $(use_enable test) \
  34. $(use_enable doc)
  35. }
  36. src_install() {
  37. default
  38. prune_libtool_files
  39. }