openexr-2.0.1-r1.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-multilib
  5. DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
  6. HOMEPAGE="http://openexr.com/"
  7. SRC_URI="http://download.savannah.gnu.org/releases/openexr/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0/2.0.1" # 2.0.1 for the namespace off -> on switch, caused library renaming
  10. KEYWORDS="~amd64 -arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
  11. IUSE="examples static-libs"
  12. RDEPEND=">=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}]
  13. >=media-libs/ilmbase-${PV}:=[${MULTILIB_USEDEP}]"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig"
  16. DOCS=( AUTHORS ChangeLog NEWS README )
  17. src_prepare() {
  18. # Fix path for testsuite
  19. sed -i -e "s:/var/tmp/:${T}:" IlmImfTest/tmpDir.h || die
  20. autotools-multilib_src_prepare
  21. }
  22. src_configure() {
  23. local myeconfargs=(
  24. $(use_enable static-libs static)
  25. $(use_enable examples imfexamples)
  26. )
  27. autotools-multilib_src_configure
  28. }
  29. src_install() {
  30. autotools-multilib_src_install \
  31. docdir=/usr/share/doc/${PF}/pdf \
  32. examplesdir=/usr/share/doc/${PF}/examples
  33. docompress -x /usr/share/doc/${PF}/examples
  34. if ! use examples; then
  35. rm -rf "${ED}"/usr/share/doc/${PF}/examples
  36. fi
  37. }