openexr_ctl-1.0.1-r2.ebuild 861 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="OpenEXR CTL libraries"
  6. HOMEPAGE="https://sourceforge.net/projects/ampasctl"
  7. SRC_URI="mirror://sourceforge/ampasctl/${P}.tar.gz"
  8. LICENSE="AMPAS"
  9. SLOT="0"
  10. KEYWORDS="amd64 hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
  11. IUSE="static-libs"
  12. RDEPEND=">=media-libs/ilmbase-2.0.1:=
  13. >=media-libs/openexr-2.0.1:=
  14. media-libs/ctl:="
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig"
  17. DOCS="AUTHORS ChangeLog NEWS README"
  18. src_prepare() {
  19. epatch \
  20. "${FILESDIR}"/${P}-{,configure_}gcc43.patch \
  21. "${FILESDIR}"/${P}-pkgconfig.patch \
  22. "${FILESDIR}"/${P}-gcc44.patch \
  23. "${FILESDIR}"/${P}-namespace.patch
  24. eautoreconf
  25. }
  26. src_configure() {
  27. econf $(use_enable static-libs static)
  28. }
  29. src_install() {
  30. default
  31. prune_libtool_files
  32. }