opus-1.1.3-r1.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit multilib-minimal
  5. if [[ ${PV} == *9999 ]] ; then
  6. inherit git-2
  7. EGIT_REPO_URI="git://git.opus-codec.org/opus.git"
  8. else
  9. SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd"
  11. fi
  12. DESCRIPTION="Open codec designed for internet transmission of interactive speech and audio"
  13. HOMEPAGE="http://opus-codec.org/"
  14. SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
  15. LICENSE="BSD-2"
  16. SLOT="0"
  17. INTRINSIC_FLAGS="cpu_flags_x86_sse neon"
  18. IUSE="ambisonics custom-modes doc static-libs ${INTRINSIC_FLAGS}"
  19. DEPEND="doc? ( app-doc/doxygen )"
  20. PATCHES=(
  21. "${FILESDIR}"/${PN}-1.1.3-CVE-2017-0381.patch
  22. )
  23. multilib_src_configure() {
  24. local myeconfargs=(
  25. $(use_enable custom-modes)
  26. $(use_enable ambisonics)
  27. $(use_enable doc)
  28. )
  29. for i in ${INTRINSIC_FLAGS} ; do
  30. use ${i} && myeconfargs+=( --enable-intrinsics )
  31. done
  32. ECONF_SOURCE="${S}" \
  33. econf "${myeconfargs[@]}"
  34. }