opusfile-0.7.ebuild 847 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A high-level decoding and seeking API for .opus files"
  5. HOMEPAGE="http://www.opus-codec.org/"
  6. SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  10. IUSE="doc fixed-point +float +http libressl static-libs"
  11. RDEPEND="media-libs/libogg
  12. media-libs/opus
  13. http? (
  14. !libressl? ( dev-libs/openssl:0= )
  15. libressl? ( dev-libs/libressl:= )
  16. )"
  17. DEPEND="${RDEPEND}
  18. doc? ( app-doc/doxygen )"
  19. REQUIRED_USE="^^ ( fixed-point float )"
  20. src_configure() {
  21. econf \
  22. --docdir=/usr/share/doc/${PF} \
  23. $(use_enable doc) \
  24. $(use_enable fixed-point)\
  25. $(use_enable float) \
  26. $(use_enable http) \
  27. $(use_enable static-libs static)
  28. }