qhull-2015.2.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils flag-o-matic
  5. DESCRIPTION="Geometry library"
  6. HOMEPAGE="http://www.qhull.org"
  7. SRC_URI="${HOMEPAGE}/download/${PN}-2015-src-7.2.0.tgz -> ${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="BSD"
  10. KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  11. IUSE="doc static-libs"
  12. DOCS=( Announce.txt File_id.diz README.txt REGISTER.txt )
  13. PATCHES=(
  14. "${FILESDIR}"/${PN}-2012.1-64bit.patch
  15. )
  16. src_configure() {
  17. append-flags -fno-strict-aliasing
  18. mycmakeargs+=(
  19. -DLIB_INSTALL_DIR="${EPREFIX}"/usr/$(get_libdir)
  20. -DDOC_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${P}/html
  21. )
  22. cmake-utils_src_configure
  23. }
  24. src_install() {
  25. cmake-utils_src_install
  26. # compatibility with previous installs
  27. dosym libqhull /usr/include/qhull
  28. if ! use doc; then
  29. rm -rf "${ED}"/usr/share/doc/${P}/html || die
  30. fi
  31. if ! use static-libs; then
  32. rm -f "${ED}"/usr/$(get_libdir)/lib*.a || die
  33. fi
  34. }