resid-0.16_p2.ebuild 917 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit autotools versionator
  5. MY_MAJ=$(get_version_component_range 1-2)
  6. DESCRIPTION="C++ library to emulate the C64 SID chip"
  7. HOMEPAGE="http://sidplay2.sourceforge.net"
  8. SRC_URI="mirror://sourceforge/sidplay2/${P/_p/-p}.tgz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 ppc sparc x86"
  12. IUSE="static-libs"
  13. RDEPEND=""
  14. DEPEND=""
  15. S=${WORKDIR}/${PN}-${MY_MAJ}
  16. src_prepare() {
  17. # This is required, otherwise the shared libraries get installed as
  18. # libresid.0.0.0 instead of libresid.so.0.0.0.
  19. eautoreconf
  20. }
  21. src_configure() {
  22. econf \
  23. --disable-dependency-tracking \
  24. --enable-shared \
  25. $(use_enable static-libs static) \
  26. --enable-resid-install
  27. }
  28. src_install () {
  29. emake DESTDIR="${D}" install || die "emake install failed"
  30. dodoc AUTHORS ChangeLog NEWS README THANKS TODO VC_CC_SUPPORT.txt
  31. }