sdif-3.11.4.ebuild 788 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils
  5. DESCRIPTION="Sound Description Interchange Format Library for audio and wave processing"
  6. HOMEPAGE="https://sourceforge.net/projects/sdif/"
  7. SRC_URI="https://sourceforge.net/projects/sdif/files/sdif/SDIF-${PV}/SDIF-${PV}-src.zip"
  8. LICENSE="LGPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~sparc ~x86"
  11. IUSE="debug ftruncate threads"
  12. PATCHES=(
  13. "${FILESDIR}/${P}-fix-buildsystem.patch"
  14. )
  15. S="${WORKDIR}/SDIF-${PV}-src"
  16. src_prepare() {
  17. mv configure.{in,ac} || die
  18. default
  19. eautoreconf
  20. }
  21. src_configure() {
  22. econf \
  23. $(use_enable debug) \
  24. $(use_enable ftruncate) \
  25. $(use_enable threads pthreads)
  26. }
  27. src_install() {
  28. default
  29. prune_libtool_files --all
  30. }