sdl-gfx-2.0.25.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils multilib-minimal
  5. MY_P="${P/sdl-/SDL_}"
  6. DESCRIPTION="Graphics drawing primitives library for SDL"
  7. HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
  8. SRC_URI="http://www.ferzkopp.net/Software/SDL_gfx-2.0/${MY_P}.tar.gz"
  9. LICENSE="ZLIB"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
  12. IUSE="doc cpu_flags_x86_mmx static-libs"
  13. RDEPEND=">=media-libs/libsdl-1.2.15-r4[video,${MULTILIB_USEDEP}]"
  14. DEPEND="${RDEPEND}"
  15. S=${WORKDIR}/${MY_P}
  16. src_prepare() {
  17. sed -i -e 's/-O //' configure.in || die
  18. mv configure.in configure.ac || die
  19. eautoreconf
  20. }
  21. multilib_src_configure() {
  22. ECONF_SOURCE="${S}" econf \
  23. --disable-dependency-tracking \
  24. $(use_enable cpu_flags_x86_mmx mmx) \
  25. $(use_enable static-libs static)
  26. }
  27. multilib_src_install() {
  28. emake DESTDIR="${D}" install
  29. }
  30. multilib_src_install_all() {
  31. dodoc AUTHORS ChangeLog README
  32. use doc && dohtml -r Docs/*
  33. prune_libtool_files
  34. }