simage-1.7.0-r1.ebuild 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Image and video texturing library"
  5. HOMEPAGE="https://bitbucket.org/Coin3D/simage"
  6. SRC_URI="https://bitbucket.org/Coin3D/coin/downloads/${P}.tar.gz"
  7. LICENSE="public-domain mpeg2enc"
  8. KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
  9. SLOT="0"
  10. IUSE="debug gif jpeg jpeg2k png sndfile static-libs tiff vorbis zlib"
  11. RESTRICT="mirror bindist" #465086
  12. RDEPEND="
  13. gif? ( media-libs/giflib )
  14. jpeg? ( virtual/jpeg:0= )
  15. jpeg2k? ( media-libs/jasper )
  16. png? ( media-libs/libpng:0= )
  17. sndfile? ( media-libs/libsndfile )
  18. tiff? ( media-libs/tiff:0= )
  19. vorbis? (
  20. media-libs/libogg
  21. media-libs/libvorbis
  22. )
  23. zlib? ( sys-libs/zlib )
  24. "
  25. DEPEND="${RDEPEND}
  26. virtual/pkgconfig
  27. "
  28. DOCS=(AUTHORS ChangeLog NEWS README)
  29. PATCHES=(
  30. "${FILESDIR}"/${PN}-1.7.0-pkgconfig-partial.patch
  31. "${FILESDIR}"/${PN}-1.7.0-libpng15.patch
  32. )
  33. # --with-pic, two defined (PIC and one for image format, sillyt), no not pass
  34. # --enable-qimage, broken Qt checks, unable to locate FHS-compliant Qt install
  35. # --with-x, not used anywhere
  36. src_configure() {
  37. econf \
  38. --disable-qimage \
  39. --disable-quicktime \
  40. --with-eps \
  41. --with-mpeg2enc \
  42. --with-rgb \
  43. --with-targa \
  44. --with-xwd \
  45. --without-x \
  46. $(use_with gif) \
  47. $(use_enable debug) \
  48. $(use_enable debug symbols) \
  49. $(use_with jpeg) \
  50. $(use_with jpeg2k jasper) \
  51. $(use_with png) \
  52. $(use_with sndfile libsndfile) \
  53. $(use_enable static-libs static) \
  54. $(use_with tiff) \
  55. $(use_with vorbis oggvorbis) \
  56. $(use_with zlib)
  57. }
  58. src_install() {
  59. # Remove simage from Libs.private
  60. sed -e '/Libs.private/s/ -lsimage//' -i simage.pc || die
  61. default
  62. # Remove libtool files when not needed.
  63. if use static-libs; then
  64. rm -f "${ED}"/usr/lib*/*.la || die
  65. fi
  66. }