simage-1.7.0.ebuild 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit base
  5. DESCRIPTION="Image and video texturing library"
  6. HOMEPAGE="https://bitbucket.org/Coin3D/simage"
  7. SRC_URI="https://bitbucket.org/Coin3D/coin/downloads/${P}.tar.gz"
  8. LICENSE="public-domain mpeg2enc"
  9. KEYWORDS="amd64 ~arm ppc x86"
  10. SLOT="0"
  11. IUSE="debug gif jpeg jpeg2k png sndfile static-libs tiff vorbis zlib"
  12. RESTRICT="mirror bindist" #465086
  13. RDEPEND="
  14. gif? ( media-libs/giflib )
  15. jpeg? ( virtual/jpeg )
  16. jpeg2k? ( media-libs/jasper )
  17. png? ( media-libs/libpng:0 )
  18. sndfile? ( media-libs/libsndfile )
  19. tiff? ( media-libs/tiff:0 )
  20. vorbis? (
  21. media-libs/libogg
  22. media-libs/libvorbis
  23. )
  24. zlib? ( sys-libs/zlib )
  25. "
  26. DEPEND="${RDEPEND}
  27. virtual/pkgconfig
  28. "
  29. DOCS=(AUTHORS ChangeLog NEWS README)
  30. PATCHES=(
  31. "${FILESDIR}"/${PN}-1.7.0-pkgconfig-partial.patch
  32. "${FILESDIR}"/${PN}-1.7.0-libpng15.patch
  33. )
  34. # --with-pic, two defined (PIC and one for image format, sillyt), no not pass
  35. # --enable-qimage, broken Qt checks, unable to locate FHS-compliant Qt install
  36. # --with-x, not used anywhere
  37. src_configure() {
  38. econf \
  39. --disable-qimage \
  40. --disable-quicktime \
  41. --with-eps \
  42. --with-mpeg2enc \
  43. --with-rgb \
  44. --with-targa \
  45. --with-xwd \
  46. --without-x \
  47. $(use_with gif) \
  48. $(use_enable debug) \
  49. $(use_enable debug symbols) \
  50. $(use_with jpeg) \
  51. $(use_with jpeg2k jasper) \
  52. $(use_with png) \
  53. $(use_with sndfile libsndfile) \
  54. $(use_enable static-libs static) \
  55. $(use_with tiff) \
  56. $(use_with vorbis oggvorbis) \
  57. $(use_with zlib)
  58. }
  59. src_install() {
  60. # Remove simage from Libs.private
  61. sed -e '/Libs.private/s/ -lsimage//' -i simage.pc || die
  62. base_src_install
  63. # Remove libtool files when not needed.
  64. use static-libs || rm -f "${D}"/usr/lib*/*.la
  65. }