tremor-0_pre20130223.ebuild 904 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # svn export http://svn.xiph.org/trunk/Tremor tremor-${PV}
  5. inherit autotools eutils
  6. DESCRIPTION="A fixed-point version of the Ogg Vorbis decoder (also known as libvorbisidec)"
  7. HOMEPAGE="http://wiki.xiph.org/Tremor"
  8. SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
  12. IUSE="low-accuracy static-libs"
  13. RDEPEND="media-libs/libogg:="
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig"
  16. DOCS="CHANGELOG README"
  17. src_prepare() {
  18. sed -i \
  19. -e '/CFLAGS/s:-O2::' \
  20. -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
  21. configure.in || die
  22. eautoreconf
  23. }
  24. src_configure() {
  25. econf \
  26. $(use_enable static-libs static) \
  27. $(use_enable low-accuracy)
  28. }
  29. src_install() {
  30. default
  31. dohtml -r doc/*
  32. prune_libtool_files
  33. }