vips-7.38.5-r1.ebuild 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils versionator python-single-r1
  6. DESCRIPTION="VIPS Image Processing Library"
  7. SRC_URI="http://www.vips.ecs.soton.ac.uk/supported/$(get_version_component_range 1-2)/${P}.tar.gz"
  8. HOMEPAGE="http://www.vips.ecs.soton.ac.uk/index.php?title=VIPS"
  9. RESTRICT="mirror"
  10. LICENSE="LGPL-2.1"
  11. SLOT="1"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="cxx debug exif fits fftw imagemagick jpeg lcms matio openexr
  14. +orc png python static-libs tiff webp"
  15. RDEPEND=">=dev-libs/glib-2.6:2
  16. dev-libs/libxml2
  17. sys-libs/zlib
  18. >=x11-libs/pango-1.8
  19. fftw? ( sci-libs/fftw:3.0= )
  20. imagemagick? ( virtual/imagemagick-tools )
  21. lcms? ( media-libs/lcms )
  22. matio? ( >=sci-libs/matio-1.3.4 )
  23. openexr? ( >=media-libs/openexr-1.2.2 )
  24. exif? ( >=media-libs/libexif-0.6 )
  25. tiff? ( media-libs/tiff:0= )
  26. jpeg? ( virtual/jpeg:0= )
  27. fits? ( sci-libs/cfitsio )
  28. png? ( >=media-libs/libpng-1.2.9:0= )
  29. python? ( ${PYTHON_DEPS} )
  30. webp? ( media-libs/libwebp )
  31. orc? ( >=dev-lang/orc-0.4.11 )"
  32. DEPEND="${RDEPEND}
  33. dev-util/gtk-doc-am"
  34. REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
  35. pkg_setup() {
  36. use python && python-single-r1_pkg_setup
  37. }
  38. src_configure() {
  39. econf \
  40. $(use_enable debug) \
  41. $(use_enable cxx) \
  42. $(use_with fftw) \
  43. $(use_with lcms) \
  44. $(use_with openexr OpenEXR) \
  45. $(use_with matio ) \
  46. $(use_with exif libexif) \
  47. $(use_with imagemagick magick) \
  48. $(use_with png) \
  49. $(use_with tiff) \
  50. $(use_with fits cfitsio) \
  51. $(use_with jpeg) \
  52. $(use_with orc) \
  53. $(use_with python) \
  54. $(use_with webp libwebp) \
  55. $(use_enable static-libs static)
  56. }
  57. src_install() {
  58. emake DESTDIR="${D}" install
  59. dodoc AUTHORS ChangeLog NEWS THANKS TODO
  60. # 314101
  61. mv "${ED}"/usr/share/doc/${PN}/* "${ED}"/usr/share/doc/${PF} || die
  62. rmdir "${ED}"/usr/share/doc/${PN}/ || die
  63. dosym /usr/share/doc/${PF} /usr/share/doc/${PN}
  64. use python && python_optimize
  65. prune_libtool_files
  66. }