gst-plugins-libav-1.8.3.ebuild 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils multilib-minimal
  5. MY_PN="gst-libav"
  6. DESCRIPTION="FFmpeg based gstreamer plugin"
  7. HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
  8. SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
  9. LICENSE="GPL-2"
  10. SLOT="1.0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
  12. IUSE="libav +orc"
  13. # XXX: bzip2/lzma are automagic
  14. RDEPEND="
  15. app-arch/bzip2
  16. app-arch/xz-utils
  17. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  18. >=media-libs/gstreamer-${PV}:1.0[${MULTILIB_USEDEP}]
  19. >=media-libs/gst-plugins-base-${PV}:1.0[${MULTILIB_USEDEP}]
  20. !libav? ( >=media-video/ffmpeg-2.8.5:0=[${MULTILIB_USEDEP}] )
  21. orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
  22. "
  23. DEPEND="${RDEPEND}
  24. >=dev-util/gtk-doc-am-1.12
  25. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
  26. "
  27. S="${WORKDIR}/${MY_PN}-${PV}"
  28. PATCHES=(
  29. # Fix compatibility with ffmpeg-2.8, by the fine Debian folks
  30. "${FILESDIR}"/${PN}-1.8.3-ffmpeg-compat.patch
  31. )
  32. multilib_src_configure() {
  33. GST_PLUGINS_BUILD=""
  34. # Upstream dropped support for system libav and won't work
  35. # for preserving its compat anymore, forcing us to rely on internal
  36. # ffmpeg copy if we don't want to cause unresolvable blockers for
  37. # libav setups.
  38. # https://bugzilla.gnome.org/show_bug.cgi?id=758183
  39. # Prefer system ffmpeg for -libav
  40. local myconf
  41. if use libav; then
  42. ewarn "Using internal ffmpeg copy as upstream dropped the"
  43. ewarn "the support for compiling against system libav"
  44. ewarn "http://bugzilla.gnome.org/show_bug.cgi?id=758183"
  45. else
  46. myconf="--with-system-libav"
  47. fi
  48. ECONF_SOURCE=${S} \
  49. econf \
  50. --disable-maintainer-mode \
  51. --with-package-name="Gentoo GStreamer ebuild" \
  52. --with-package-origin="https://www.gentoo.org" \
  53. --disable-fatal-warnings \
  54. $(use_enable orc) \
  55. ${myconf}
  56. }
  57. multilib_src_compile() {
  58. # Don't build with -Werror
  59. emake ERROR_CFLAGS=
  60. }
  61. multilib_src_install_all() {
  62. einstalldocs
  63. prune_libtool_files --modules
  64. }