vdr-autosort-0.1.3.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit vdr-plugin-2
  5. DESCRIPTION="VDR plugin: Auto-sort channels.conf"
  6. HOMEPAGE="http://www.copypointburscheid.de/linux/autosort.htm"
  7. SRC_URI="http://www.copypointburscheid.de/linux/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~x86 ~amd64"
  11. IUSE=""
  12. DEPEND=">=media-video/vdr-1.3.32"
  13. RDEPEND="${DEPEND}"
  14. src_install() {
  15. vdr-plugin-2_src_install
  16. insinto /etc/vdr/plugins
  17. doins examples/autosort.conf
  18. }
  19. pkg_preinst() {
  20. if [[ ! -L ${ROOT}/etc/vdr/channels.conf ]]; then
  21. cp "${ROOT}"/etc/vdr/channels.conf "${D}"/etc/vdr/channels.conf.autosort.bak
  22. fowners vdr:vdr /etc/vdr/channels.conf.autosort.bak
  23. fi
  24. }
  25. pkg_postinst() {
  26. vdr-plugin-2_pkg_postinst
  27. echo
  28. elog "You will find a backup of your channels.conf in /etc/vdr/channels.conf.autosort.bak"
  29. elog "Edit /etc/vdr/plugins/autosort.conf to fit your needs"
  30. ewarn "Important:"
  31. ewarn "Backup your channels.conf together with autosort.conf"
  32. ewarn "before making heavy changes to autosort.conf."
  33. echo
  34. }