xbmc-addon-xvdr-9999.ebuild 920 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit git-2 autotools multilib
  5. EGIT_REPO_URI="git://github.com/pipelka/xbmc-addon-xvdr.git"
  6. DESCRIPTION="XBMC addon: add VDR (http://www.tvdr.de/) as a TV/PVR Backend"
  7. HOMEPAGE="https://github.com/pipelka/xbmc-addon-xvdr"
  8. SRC_URI=""
  9. KEYWORDS=""
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND="${DEPEND}"
  15. S=${WORKDIR}/${PN}
  16. src_prepare() {
  17. eautoreconf
  18. }
  19. src_configure() {
  20. econf --prefix=/usr/$(get_libdir)/xbmc
  21. }
  22. src_install() {
  23. emake DESTDIR="${D}" install || die "emake install failed"
  24. }
  25. pkg_info() {
  26. einfo "This add-on requires the installed "media-lugins/vdr-xvdr" plugin on the VDR server."
  27. einfo "VDR itself dosn't need any patches or modification to use all the current features."
  28. einfo "IMPORTANT:"
  29. einfo "Please disable *all* PVR addons *before* running the XVDR addon!"
  30. }