dvbtune-0.5-r1.ebuild 633 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="simple tuning app for DVB cards"
  6. HOMEPAGE="https://sourceforge.net/projects/dvbtools"
  7. SRC_URI="mirror://sourceforge/dvbtools/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="xml"
  12. RDEPEND="xml? ( dev-libs/libxml2 )"
  13. DEPEND="${RDEPEND}
  14. virtual/linuxtv-dvb-headers"
  15. src_prepare() {
  16. epatch "${FILESDIR}"/${PF}-gentoo.diff
  17. }
  18. src_compile() {
  19. emake dvbtune
  20. use xml && emake xml2vdr
  21. }
  22. src_install() {
  23. dobin dvbtune
  24. use xml && dobin xml2vdr
  25. dodoc README scripts/*
  26. }