kino-1.3.4.ebuild 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils udev
  5. DESCRIPTION="Kino is a non-linear DV editor for GNU/Linux"
  6. HOMEPAGE="http://www.kinodv.org/"
  7. SRC_URI="mirror://sourceforge/kino/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ppc64 ~sparc x86"
  11. IUSE="alsa dvdr gpac lame gstreamer quicktime sox vorbis"
  12. # This ebuild would benefit a lot of USE dependencies but that has to wait for
  13. # EAPI 2. The usual fix is to issue built_with_use checks but in that particu-
  14. # lar case it would make the ebuild rather complicated to write and maintain
  15. # (certain features can be enabled in various different ways). Also it would
  16. # also force the emerge process to stop a bit too often for users not to comp-
  17. # lain. Thus, if you need features like theora, x264, xvid and maybe others,
  18. # make sure you activate the required support where it should be (ffmpeg, mostly).
  19. # Optional dependency on cinelerra-cvs (as a replacement for libquicktime)
  20. # dropped because kino may run with it but won't build anymore.
  21. CDEPEND=">=x11-libs/gtk+-2.6.0:2
  22. >=gnome-base/libglade-2.5.0
  23. >=dev-libs/glib-2:2
  24. x11-libs/libXv
  25. dev-libs/libxml2:2
  26. media-libs/audiofile
  27. >=sys-libs/libraw1394-1.0.0
  28. >=sys-libs/libavc1394-0.4.1
  29. >=media-libs/libdv-0.103
  30. media-libs/libsamplerate
  31. media-libs/libiec61883
  32. media-libs/libv4l
  33. alsa? ( >=media-libs/alsa-lib-1.0.9 )
  34. virtual/ffmpeg
  35. quicktime? ( >=media-libs/libquicktime-0.9.5 )"
  36. DEPEND="${CDEPEND}
  37. dev-util/intltool"
  38. RDEPEND="${CDEPEND}
  39. media-video/mjpegtools
  40. media-sound/rawrec
  41. dvdr? ( media-video/dvdauthor
  42. app-cdr/dvd+rw-tools )
  43. gpac? ( media-video/gpac )
  44. lame? ( media-sound/lame )
  45. gstreamer? ( media-libs/gst-plugins-base:0.10 )
  46. sox? ( media-sound/sox )
  47. vorbis? ( media-sound/vorbis-tools )"
  48. DOCS="AUTHORS BUGS ChangeLog NEWS README* TODO"
  49. src_prepare() {
  50. # Deactivating automagic alsa configuration, bug #134725
  51. if ! use alsa ; then
  52. sed -i -e "s:HAVE_ALSA 1:HAVE_ALSA 0:" configure || die
  53. fi
  54. # Fix bug #169590
  55. # https://sourceforge.net/tracker/?func=detail&aid=3304495&group_id=14103&atid=314103
  56. sed -i \
  57. -e '/\$(LIBQUICKTIME_LIBS) \\/d' \
  58. -e '/^[[:space:]]*\$(SRC_LIBS)/ a\
  59. \$(LIBQUICKTIME_LIBS) \\' \
  60. src/Makefile.in || die
  61. # Fix test failure discovered in bug #193947
  62. # https://sourceforge.net/tracker/?func=detail&aid=3304499&group_id=14103&atid=314103
  63. sed -i -e '$a\
  64. \
  65. ffmpeg/libavcodec/ps2/idct_mmi.c\
  66. ffmpeg/libavcodec/sparc/dsputil_vis.c\
  67. ffmpeg/libavcodec/sparc/vis.h\
  68. ffmpeg/libavutil/bswap.h\
  69. ffmpeg/libswscale/yuv2rgb_template.c\
  70. src/export.h\
  71. src/message.cc\
  72. src/page_bttv.cc' po/POTFILES.in || die
  73. sed -i -e 's:^#include <quicktime.h>:#include <lqt/quicktime.h>:' src/filehandler.h || die
  74. epatch "${FILESDIR}/${P}-v4l1.patch"
  75. epatch "${FILESDIR}/${P}-libav-0.7.patch"
  76. epatch "${FILESDIR}/${P}-libav-0.8.patch"
  77. epatch "${FILESDIR}/${P}-libavcodec-pkg-config.patch"
  78. eautoreconf
  79. }
  80. src_configure() {
  81. econf \
  82. --disable-local-ffmpeg \
  83. $(use_enable quicktime) \
  84. $(use_with sparc dv1394) \
  85. --with-udev-rules-dir="$(get_udevdir)"/rules.d \
  86. CPPFLAGS="-I${ROOT}usr/include/libavcodec -I${ROOT}usr/include/libavformat -I${ROOT}usr/include/libswscale"
  87. }
  88. src_install() {
  89. default
  90. mv "${ED}/$(get_udevdir)"/rules.d/{,99-}kino.rules
  91. fowners root:root -R /usr/share/kino/help #177378
  92. prune_libtool_files --all #385361
  93. }