movit-1.3.0.ebuild 743 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # no sane way to use OpenGL from within tests?
  5. RESTRICT="test"
  6. DESCRIPTION="Modern Video Toolkit"
  7. HOMEPAGE="http://movit.sesse.net/"
  8. # Tests need gtest, makefile unconditionally builds tests, so ... yey!
  9. SRC_URI="http://movit.sesse.net/${P}.tar.gz
  10. https://googletest.googlecode.com/files/gtest-1.7.0.zip"
  11. LICENSE="GPL-2+"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~ppc64 ~x86"
  14. IUSE=""
  15. RDEPEND="media-libs/mesa
  16. >=dev-cpp/eigen-3.2.0:3
  17. media-libs/libepoxy
  18. sci-libs/fftw
  19. media-libs/libsdl2
  20. "
  21. DEPEND="${RDEPEND}"
  22. src_compile() {
  23. GTEST_DIR="${WORKDIR}/gtest-1.7.0" emake
  24. }
  25. src_test() {
  26. GTEST_DIR="${WORKDIR}/gtest-1.7.0" emake check
  27. }