mpglen-0.1.ebuild 640 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2007 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit flag-o-matic toolchain-funcs
  4. DESCRIPTION="A program to scan through a MPEG file and count the number of GOPs and frames"
  5. HOMEPAGE="http://www.iamnota.net/mpglen/"
  6. SRC_URI="http://www.iamnota.net/mpglen/${PN}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc ~x86"
  10. IUSE=""
  11. S=${WORKDIR}/${PN}
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. echo 'all: mpglen' > Makefile
  16. append-lfs-flags
  17. }
  18. src_compile() {
  19. tc-export CC
  20. emake || die "emake failed"
  21. }
  22. src_install () {
  23. dobin ${PN} || die
  24. dodoc AUTHORS Changelog README
  25. }