parole-0.9.1.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A simple Xfce4 media player using GStreamer"
  5. HOMEPAGE="http://goodies.xfce.org/projects/applications/parole/"
  6. SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~mips ~x86"
  10. IUSE="clutter libnotify taglib"
  11. COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
  12. >=dev-libs/glib-2.32:2=
  13. media-libs/gstreamer:1.0=
  14. media-libs/gst-plugins-base:1.0=
  15. sys-apps/dbus:0=
  16. >=x11-libs/gtk+-3.14:3=
  17. x11-libs/libX11:0=
  18. >=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
  19. >=xfce-base/libxfce4util-4.11:0=
  20. >=xfce-base/xfconf-4.10:0=
  21. clutter? (
  22. >=media-libs/clutter-1.16.4:1.0=
  23. >=media-libs/clutter-gtk-1.4.4:1.0=
  24. <x11-libs/gtk+-3.22:3
  25. )
  26. libnotify? ( >=x11-libs/libnotify-0.7:0= )
  27. taglib? ( >=media-libs/taglib-1.6:0= )"
  28. RDEPEND="${COMMON_DEPEND}
  29. media-plugins/gst-plugins-meta:1.0"
  30. DEPEND="${COMMON_DEPEND}
  31. dev-util/intltool
  32. sys-devel/gettext
  33. virtual/pkgconfig
  34. x11-proto/xproto"
  35. DOCS=( AUTHORS ChangeLog README THANKS TODO )
  36. src_configure() {
  37. local myconf=(
  38. $(use_enable clutter)
  39. $(use_enable taglib)
  40. $(use_enable libnotify notify-plugin)
  41. --with-gstreamer=1.0
  42. )
  43. econf "${myconf[@]}"
  44. }