plasma-mediacenter-5.7.5.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. KDE_TEST="forceoptional"
  5. inherit kde5
  6. DESCRIPTION="Unified media experience for any device capable of running KDE Plasma"
  7. SRC_URI="mirror://kde/stable/plasma/${PV}/${P}.tar.xz"
  8. KEYWORDS="amd64 ~arm x86"
  9. IUSE="semantic-desktop"
  10. DEPEND="
  11. $(add_frameworks_dep kactivities)
  12. $(add_frameworks_dep kconfig)
  13. $(add_frameworks_dep kcoreaddons)
  14. $(add_frameworks_dep kdeclarative)
  15. $(add_frameworks_dep kguiaddons)
  16. $(add_frameworks_dep ki18n)
  17. $(add_frameworks_dep kio)
  18. $(add_frameworks_dep kservice)
  19. $(add_frameworks_dep plasma)
  20. $(add_qt_dep qtdbus)
  21. $(add_qt_dep qtdeclarative)
  22. $(add_qt_dep qtgui)
  23. $(add_qt_dep qtnetwork)
  24. $(add_qt_dep qtxml)
  25. media-libs/taglib
  26. semantic-desktop? (
  27. $(add_frameworks_dep baloo)
  28. $(add_frameworks_dep kfilemetadata)
  29. )
  30. "
  31. RDEPEND="${DEPEND}
  32. $(add_plasma_dep plasma-workspace)
  33. $(add_qt_dep qtmultimedia 'qml')
  34. !media-video/plasma-mediacenter:0
  35. "
  36. src_configure() {
  37. local mycmakeargs=(
  38. $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
  39. $(cmake-utils_use_find_package semantic-desktop KF5FileMetadata)
  40. )
  41. kde5_src_configure
  42. }