cutecom-0.22.0-r1.ebuild 803 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils eutils
  5. DESCRIPTION="CuteCom is a serial terminal, like minicom, written in qt"
  6. HOMEPAGE="http://cutecom.sourceforge.net"
  7. SRC_URI="http://cutecom.sourceforge.net/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND="dev-qt/qtcore:4
  13. dev-qt/qtgui:4
  14. dev-qt/qt3support:4"
  15. RDEPEND="${DEPEND}
  16. net-dialup/lrzsz"
  17. src_prepare() {
  18. sed -i \
  19. -e '/Path/d' \
  20. -e '/TerminalOptions/d' \
  21. -e '/BinaryPattern/d' \
  22. -e '/Terminal/s/0/false/' \
  23. ${PN}.desktop || die 'sed on desktop file failed'
  24. cmake-utils_src_prepare
  25. }
  26. src_install() {
  27. cmake-utils_src_install
  28. # desktop icon does not installed by cmake without KDE3
  29. domenu ${PN}.desktop
  30. }