pptpclient-1.8.0.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils toolchain-funcs
  5. MY_P="${P/client}"
  6. MY_CMD="pptp-command-20130515"
  7. DESCRIPTION="Linux client for PPTP"
  8. HOMEPAGE="http://pptpclient.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/pptpclient/${MY_P}.tar.gz
  10. https://dev.gentoo.org/~pinkbyte/distfiles/pptpclient/${MY_CMD}.bz2"
  11. SLOT="0"
  12. LICENSE="GPL-2"
  13. KEYWORDS="alpha amd64 ~arm ppc ppc64 x86"
  14. IUSE="tk"
  15. DEPEND="net-dialup/ppp
  16. dev-lang/perl
  17. tk? ( dev-perl/Tk )"
  18. RDEPEND="${DEPEND}
  19. sys-apps/iproute2"
  20. RESTRICT="test" #make test is useless and vector_test.c is broken
  21. S="${WORKDIR}/${MY_P}"
  22. DOCS=( AUTHORS ChangeLog DEVELOPERS NEWS README TODO USING )
  23. src_prepare() {
  24. epatch "${FILESDIR}"/${P}-process-name.patch
  25. epatch_user
  26. }
  27. src_compile() {
  28. emake OPTIMISE= DEBUG= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
  29. }
  30. src_install() {
  31. default
  32. dodoc Documentation/*
  33. dodir /etc/pptp.d
  34. # The current version of pptp-linux doesn't include the
  35. # RH-specific portions, so include them ourselves.
  36. newsbin "${WORKDIR}/${MY_CMD}" pptp-command
  37. dosbin "${FILESDIR}/pptp_fe.pl"
  38. use tk && dosbin "${FILESDIR}/xpptp_fe.pl"
  39. }