sercd-3.0.0-r2.ebuild 656 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="RFC2217-compliant serial port redirector"
  6. HOMEPAGE="https://sourceforge.net/projects/sercd"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="xinetd"
  12. RDEPEND="xinetd? ( virtual/inetd )"
  13. DOCS=( AUTHORS README )
  14. src_prepare() {
  15. eapply_user
  16. }
  17. src_install () {
  18. default
  19. newinitd "${FILESDIR}/${PN}.initd" "${PN}"
  20. newconfd "${FILESDIR}/${PN}.confd" "${PN}"
  21. if use xinetd ; then
  22. insinto /etc/xinetd.d
  23. newins "${FILESDIR}/${PN}.xinetd" "${PN}"
  24. fi
  25. }