dnscap-20130814.ebuild 692 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="dnscap is a network capture utility designed specifically for DNS traffic"
  6. HOMEPAGE="http://dnscap.dns-oarc.net/"
  7. ## github commit tarball
  8. MY_GIT_COMMIT="727ed7d5e46625abc2c8d988689a300589e948b6"
  9. MY_P="verisign-${PN}-${MY_GIT_COMMIT:0:7}"
  10. SRC_URI="https://github.com/verisign/${PN}/tarball/${MY_GIT_COMMIT} -> ${PF}.tar.gz"
  11. S="${WORKDIR}/${MY_P}"
  12. KEYWORDS="~amd64 ~x86"
  13. SLOT="0"
  14. LICENSE="ISC"
  15. IUSE=""
  16. RDEPEND="net-libs/libpcap"
  17. DEPEND="${RDEPEND}"
  18. src_prepare() {
  19. ## adds DESTDIR to install target
  20. epatch "${FILESDIR}/${P}.install.patch"
  21. }