dnstop-20140915.ebuild 601 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Displays various tables of DNS traffic on your network"
  6. HOMEPAGE="http://dnstop.measurement-factory.com/"
  7. SRC_URI="http://dnstop.measurement-factory.com/src/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ~hppa ~ppc x86"
  11. IUSE="ipv6"
  12. RDEPEND="sys-libs/ncurses
  13. net-libs/libpcap"
  14. DEPEND="${RDEPEND}"
  15. src_prepare() {
  16. epatch_user
  17. }
  18. src_configure() {
  19. econf \
  20. $(use_enable ipv6)
  21. }
  22. src_install() {
  23. dobin dnstop
  24. doman dnstop.8
  25. dodoc CHANGES
  26. }