fwbuilder-5.0.1.3592-r1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils base qt4-r2 multilib autotools
  5. DESCRIPTION="A firewall GUI"
  6. HOMEPAGE="http://www.fwbuilder.org/"
  7. SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ppc64 x86"
  11. IUSE=""
  12. DEPEND=">=dev-qt/qtgui-4.3:4
  13. dev-libs/openssl
  14. dev-libs/elfutils"
  15. RDEPEND="${DEPEND}"
  16. PATCHES=(
  17. "${FILESDIR}/${PN}-5.0.0.3568-ldflags.patch"
  18. "${FILESDIR}/${PN}-5.0.1.3592-gcc47.patch"
  19. )
  20. src_prepare() {
  21. # Fix a compile bug that affects some x86_64 platforms.
  22. # Addressed in the upcoming 5.0.2.3596 release.
  23. # Closes #395151.
  24. epatch "${FILESDIR}/${P}-stdc-format-macros.patch"
  25. qt4-r2_src_prepare
  26. sed -i -e '/dnl.*AM_INIT_AUTOMAKE/d' configure.in || die #398743
  27. eautoreconf
  28. }
  29. src_configure() {
  30. eqmake4
  31. # portage handles ccache/distcc itself
  32. econf --without-{ccache,distcc}
  33. }
  34. src_install() {
  35. emake INSTALL_ROOT="${D}" install
  36. }
  37. pkg_postinst() {
  38. validate_desktop_entries
  39. elog "You need to emerge sys-apps/iproute2 on the machine"
  40. elog "that will run the firewall script."
  41. }