shapecfg-36.ebuild 721 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils flag-o-matic
  4. DESCRIPTION="configuration tool for setting traffic bandwidth parameters"
  5. HOMEPAGE="ftp://archive.download.redhat.com/pub/redhat/linux/9/en/os/i386/SRPMS https://sourceforge.net/projects/cbqinit"
  6. SRC_URI="mirror://gentoo/shaper.${PV}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~arm ~x86"
  10. IUSE=""
  11. DEPEND=""
  12. S=${WORKDIR}/shaper
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${FILESDIR}"/shapercfg-2.0.36-glibc.patch
  17. rm -f Makefile
  18. }
  19. src_compile() {
  20. append-flags -Wall
  21. emake shapecfg || die
  22. }
  23. src_install() {
  24. dobin shapecfg || die
  25. dodoc "${FILESDIR}"/README.shaper
  26. }