btfs-2.12.ebuild 804 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python{2_7,3_4,3_5} )
  5. inherit autotools python-r1
  6. DESCRIPTION="a bittorrent filesystem based on FUSE"
  7. HOMEPAGE="https://github.com/johang/btfs"
  8. SRC_URI="https://github.com/johang/btfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. CDEPEND=">=sys-fs/fuse-2.8.0
  13. >=net-misc/curl-7.22.0
  14. dev-libs/boost:=
  15. >=net-libs/libtorrent-rasterbar-0.16.0:="
  16. DEPEND="${CDEPEND}
  17. virtual/pkgconfig"
  18. RDEPEND="${CDEPEND}
  19. ${PYTHON_DEPS}"
  20. src_prepare() {
  21. default
  22. # don't install btplay via make
  23. sed -i '/^SUBDIRS =/s/scripts//' Makefile.am || die
  24. eautoreconf
  25. }
  26. src_install() {
  27. default
  28. python_foreach_impl python_doscript scripts/btplay
  29. }