libnfs-1.9.8.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. AUTOTOOLS_AUTORECONF="1"
  5. inherit eutils
  6. if [[ ${PV} == "9999" ]] ; then
  7. EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
  8. inherit git-2 autotools-utils
  9. else
  10. SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
  12. inherit autotools-utils
  13. fi
  14. DESCRIPTION="Client library for accessing NFS shares over a network"
  15. HOMEPAGE="https://github.com/sahlberg/libnfs"
  16. LICENSE="LGPL-2.1 GPL-3"
  17. SLOT="0/8" # sub-slot matches SONAME major
  18. IUSE="examples static-libs"
  19. RDEPEND=""
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig"
  22. S="${WORKDIR}/${PN}-${P}"
  23. src_install() {
  24. autotools-utils_src_install
  25. if use examples; then
  26. # --enable-examples configure switch just compiles them
  27. # better install sources instead
  28. exeinto /usr/share/doc/${PF}/examples/
  29. for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
  30. doexe examples/${program}.c
  31. done
  32. fi
  33. }