centerim-5.0.0_beta2.ebuild 838 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. MY_P="${PN}5-${PV/_}"
  5. DESCRIPTION="CenterIM is a ncurses ICQ/Yahoo!/AIM/IRC/MSN/Jabber/GaduGadu/RSS/LiveJournal Client"
  6. SRC_URI="http://www.centerim.org/download/cim5/${MY_P}.tar.gz"
  7. HOMEPAGE="http://www.centerim.org/"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. KEYWORDS="~amd64 ~x86 ~x86-fbsd"
  11. IUSE="debug nls"
  12. DEPEND=">=sys-libs/ncurses-5.2
  13. >=net-im/pidgin-2.7.0
  14. >=dev-libs/glib-2.16.0
  15. >=dev-libs/libsigc++-2.2.0"
  16. RDEPEND="${DEPEND}
  17. nls? ( sys-devel/gettext )"
  18. DEPEND="${DEPEND}
  19. virtual/pkgconfig"
  20. S="${WORKDIR}"/${MY_P}
  21. src_configure() {
  22. econf \
  23. $(use_enable debug) \
  24. $(use_enable nls)
  25. }
  26. src_install() {
  27. emake DESTDIR="${D}" install
  28. rm -f "${D}"/usr/lib*/libcppconsui.{a,la}
  29. dodoc AUTHORS HACKING NEWS README TODO
  30. }