jabber-base-0.01-r1.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils user
  5. DESCRIPTION="Jabber servers and transports layout package"
  6. SRC_URI=""
  7. HOMEPAGE="https://www.gentoo.org/"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
  11. IUSE=""
  12. DEPEND=""
  13. S="${WORKDIR}"
  14. #Info for people working in jabber related packages
  15. #/etc/jabber/ for configuration files
  16. #/var/run/jabber/ for the pid files
  17. #/var/spool/jabber/ for the flat files databases (actually there must be a ewarn
  18. #at end of ebuild telling user to creat /var/spool/jabber/JID, as some transports fail to start if
  19. #the directory is not there, even if they have permissions to creat it)
  20. #/var/log/jabber/ for the log files
  21. #for the python based transports with no install script:
  22. #they must inherit python and be installed in:
  23. #$(python_get_sitedir)/$package-name
  24. #the user should be the one created here username=group=jabber
  25. src_install() {
  26. keepdir /etc/jabber
  27. keepdir /var/run/jabber
  28. keepdir /var/spool/jabber
  29. keepdir /var/log/jabber
  30. }
  31. pkg_postinst() {
  32. # Users should not be created in src_install see bug #124680
  33. # Add our default jabber group and user
  34. enewgroup jabber
  35. enewuser jabber -1 -1 -1 jabber
  36. # We can't use fowners & fperms convenience wrappers as we are outside the sandbox
  37. chown jabber:jabber /etc/jabber /var/log/jabber /var/spool/jabber /var/run/jabber
  38. chmod 770 /etc/jabber /var/log/jabber /var/spool/jabber /var/run/jabber
  39. }