cgiirc-0.5.10.ebuild 879 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit webapp eutils
  5. DESCRIPTION="A perl/CGI program to use IRC from a web browser"
  6. HOMEPAGE="http://cgiirc.org/"
  7. SRC_URI="http://cgiirc.org/releases/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. KEYWORDS="~amd64 ~ppc ~x86"
  10. IUSE=""
  11. need_httpd_cgi
  12. pkg_setup() {
  13. webapp_pkg_setup
  14. elog "Note that file locations have changed."
  15. elog "CGI:IRC will be installed into cgi-bin/${P}"
  16. }
  17. src_unpack() {
  18. unpack ${A}
  19. cd "${S}"
  20. ecvs_clean
  21. }
  22. src_install() {
  23. webapp_src_preinst
  24. local docs="README cgiirc.config.full ipaccess.example"
  25. dodoc docs/{CHANGES,TODO} ${docs}
  26. dohtml docs/help.html
  27. rm -rf docs/ ${docs}
  28. insinto "${MY_CGIBINDIR}"/${P}
  29. doins -r .
  30. fperms +x "${MY_CGIBINDIR}"/${P}/irc.cgi
  31. webapp_configfile "${MY_CGIBINDIR}"/${P}/cgiirc.config
  32. webapp_src_install
  33. }