irker-2.11.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="ssl"
  6. inherit python-single-r1 eutils
  7. DESCRIPTION="Submission tools for IRC notifications"
  8. HOMEPAGE="http://www.catb.org/esr/irker/"
  9. SRC_URI="http://www.catb.org/esr/${PN}/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. DEPEND="app-text/docbook-xml-dtd:4.1.2
  15. app-text/xmlto"
  16. src_prepare() {
  17. # https://gitorious.org/irker/irker/merge_requests/25
  18. epatch "${FILESDIR}/2.7-Register-author_name-as-author-instead-of-email-user.patch"
  19. epatch "${FILESDIR}/2.7-irkerhook-Remove-file-listing.patch"
  20. # Prefix support
  21. sed -i -e "/^ExecStart=/ s:=/:=${EROOT}:" irkerd.service \
  22. || die "sed failed"
  23. }
  24. src_install() {
  25. emake DESTDIR="${ED}" install
  26. python_doscript "${ED}/usr/bin/irkerd"
  27. # Not installed with the default Makefile
  28. python_doscript irk irkerhook.py
  29. newinitd "${FILESDIR}/irkerd.initd" irkerd
  30. newconfd "${FILESDIR}/irkerd.confd" irkerd
  31. dodoc NEWS README hacking.txt security.txt
  32. dohtml irkerd.html irkerhook.html
  33. docinto examples
  34. dodoc filter-example.py filter-test.py
  35. }