irker-2.16.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4} )
  5. PYTHON_REQ_USE="ssl"
  6. inherit python-single-r1 systemd eutils
  7. DESCRIPTION="Submission tools for IRC notifications"
  8. HOMEPAGE="http://www.catb.org/esr/irker/"
  9. SRC_URI="http://www.catb.org/esr/${PN}/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~arm ~x86"
  13. IUSE=""
  14. DEPEND="app-text/docbook-xml-dtd:4.1.2
  15. app-text/xmlto"
  16. src_prepare() {
  17. # https://gitorious.org/irker/irker/merge_requests/25
  18. epatch "${FILESDIR}/2.7-Register-author_name-as-author-instead-of-email-user.patch"
  19. epatch "${FILESDIR}/2.7-irkerhook-Remove-file-listing.patch"
  20. # Rely on systemd eclass for systemd service install
  21. sed -i -e "/^SYSTEMDSYSTEMUNITDIR/d" Makefile \
  22. || die "sed failed"
  23. # Prefix support
  24. sed -i -e "/^ExecStart=/ s:=/:=${EROOT}:" irkerd.service \
  25. || die "sed failed"
  26. }
  27. src_install() {
  28. emake DESTDIR="${ED}" install
  29. python_doscript "${ED}/usr/bin/irkerd"
  30. # Not installed with the default Makefile
  31. python_doscript irk irkerhook.py
  32. newinitd "${FILESDIR}/irkerd.initd" irkerd
  33. newconfd "${FILESDIR}/irkerd.confd" irkerd
  34. systemd_dounit irkerd.service
  35. dodoc NEWS README hacking.txt security.txt
  36. dohtml irkerd.html irkerhook.html
  37. docinto examples
  38. dodoc filter-example.py filter-test.py
  39. }