irker-2.17.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4} )
  5. PYTHON_REQ_USE="ssl"
  6. inherit python-single-r1 systemd eutils
  7. DESCRIPTION="Submission tools for IRC notifications"
  8. HOMEPAGE="http://www.catb.org/esr/irker/"
  9. SRC_URI="http://www.catb.org/esr/${PN}/${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="socks5"
  14. DEPEND="app-text/docbook-xml-dtd:4.1.2
  15. app-text/xmlto
  16. socks5? ( dev-python/PySocks[${PYTHON_USEDEP}] )"
  17. src_prepare() {
  18. # https://gitorious.org/irker/irker/merge_requests/25
  19. epatch "${FILESDIR}/2.7-Register-author_name-as-author-instead-of-email-user.patch"
  20. epatch "${FILESDIR}/2.17-irkerhook-Remove-file-listing.patch"
  21. # Rely on systemd eclass for systemd service install
  22. sed -i -e "/^SYSTEMDSYSTEMUNITDIR/d" Makefile \
  23. || die "sed failed"
  24. # Prefix support
  25. sed -i -e "/^ExecStart=/ s:=/:=${EROOT}:" irkerd.service \
  26. || die "sed failed"
  27. }
  28. src_install() {
  29. emake DESTDIR="${ED}" install
  30. python_doscript "${ED}/usr/bin/irkerd"
  31. # Not installed with the default Makefile
  32. python_doscript irk irkerhook.py
  33. newinitd "${FILESDIR}/irkerd.initd" irkerd
  34. newconfd "${FILESDIR}/irkerd.confd" irkerd
  35. systemd_dounit irkerd.service
  36. dodoc NEWS README hacking.txt security.txt
  37. dohtml irkerd.html irkerhook.html
  38. docinto examples
  39. dodoc filter-example.py filter-test.py
  40. }