muh-2.2a.ebuild 790 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2007 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="Persistent IRC bouncer"
  4. HOMEPAGE="http://mind.riot.org/muh/"
  5. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  6. LICENSE="GPL-2"
  7. SLOT="0"
  8. KEYWORDS="alpha ~amd64 ~hppa ~mips ppc ~sparc x86"
  9. IUSE="ipv6"
  10. DEPEND=""
  11. src_compile() {
  12. econf --datadir=/usr/share/muh $(use_enable ipv6) || die "econf failed"
  13. emake || die "emake failed"
  14. }
  15. src_install() {
  16. emake DESTDIR="${D}" install || die "emake install failed"
  17. dodoc AUTHORS ChangeLog TODO
  18. }
  19. pkg_postinst() {
  20. elog
  21. elog "You'll need to configure muh before running it."
  22. elog "Put your config in ~/.muh/muhrc"
  23. elog "A sample config is /usr/share/muh/muhrc"
  24. elog "For more information, see the documentation."
  25. elog
  26. }