aqbanking-5.4.3_beta.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. MY_P="${P/_beta/beta}"
  6. DESCRIPTION="Generic Online Banking Interface"
  7. HOMEPAGE="http://www.aquamaniac.de/aqbanking/"
  8. SRC_URI="http://www.aquamaniac.de/sites/download/download.php?package=03&release=115&file=01&dummy=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
  9. S="${WORKDIR}/${MY_P}"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  13. IUSE="chipcard debug doc examples gtk ofx"
  14. RDEPEND=">=app-misc/ktoblzcheck-1.45
  15. >=dev-libs/gmp-5
  16. >=sys-libs/gwenhywfar-4.12.0_beta[gtk?]
  17. virtual/libintl
  18. ofx? ( >=dev-libs/libofx-0.9.5 )
  19. chipcard? ( >=sys-libs/libchipcard-5.0.2 )"
  20. DEPEND="${RDEPEND}
  21. sys-devel/gettext
  22. virtual/pkgconfig
  23. doc? ( app-doc/doxygen )"
  24. MAKEOPTS="${MAKEOPTS} -j1" # 5.0.x fails with -j9 on quadcore
  25. src_configure() {
  26. local backends="aqhbci aqnone aqpaypal"
  27. use ofx && backends="${backends} aqofxconnect"
  28. local mytest
  29. use gtk && mytest="--enable-gui-tests"
  30. econf \
  31. $(use_enable debug) \
  32. $(use_enable doc full-doc) \
  33. --with-backends="${backends}" \
  34. --with-docpath=/usr/share/doc/${PF}/apidoc \
  35. ${mytest}
  36. }
  37. src_install() {
  38. emake DESTDIR="${D}" install
  39. rm -rf "${ED}"/usr/share/doc/aq{banking,hbci,paypal}
  40. dodoc AUTHORS ChangeLog NEWS README TODO
  41. newdoc src/plugins/backends/aqhbci/tools/aqhbci-tool/README \
  42. README.aqhbci-tool
  43. if use examples; then
  44. docinto tutorials
  45. dodoc tutorials/*.{c,h} tutorials/README
  46. fi
  47. prune_libtool_files --all
  48. }