czmq-2.2.0-r2.ebuild 851 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=true
  5. inherit autotools-utils
  6. DESCRIPTION=" High-level C Binding for ZeroMQ"
  7. HOMEPAGE="http://czmq.zeromq.org"
  8. SRC_URI="http://download.zeromq.org/${P}.tar.gz"
  9. LICENSE="LGPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64 arm hppa x86"
  12. IUSE="doc static-libs"
  13. RDEPEND="
  14. dev-libs/libsodium:=
  15. sys-apps/util-linux
  16. >=net-libs/zeromq-2.1
  17. <net-libs/zeromq-4
  18. "
  19. DEPEND="${RDEPEND}
  20. doc? (
  21. app-text/asciidoc
  22. app-text/xmlto
  23. )"
  24. DOCS=( NEWS AUTHORS )
  25. src_prepare() {
  26. sed -i -e 's|-Werror||g' configure.ac || die
  27. autotools-utils_src_prepare
  28. }
  29. src_install() {
  30. autotools-utils_src_install
  31. mv "${ED}"/usr/bin/makecert{,-czmq} || die
  32. }
  33. pkg_postinst() {
  34. elog "Due to file collisions we moved the makecert tool to makecert-${PN}."
  35. }