glib-networking-2.50.0.ebuild 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. inherit gnome2 multilib-minimal virtualx
  6. DESCRIPTION="Network-related giomodules for glib"
  7. HOMEPAGE="https://git.gnome.org/browse/glib-networking/"
  8. LICENSE="LGPL-2+"
  9. SLOT="0"
  10. IUSE="+gnome +libproxy smartcard +ssl test"
  11. KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
  12. RDEPEND="
  13. >=dev-libs/glib-2.46.0:2[${MULTILIB_USEDEP}]
  14. gnome? ( gnome-base/gsettings-desktop-schemas )
  15. libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
  16. smartcard? (
  17. >=app-crypt/p11-kit-0.18.4[${MULTILIB_USEDEP}]
  18. >=net-libs/gnutls-3:=[pkcs11,${MULTILIB_USEDEP}] )
  19. ssl? (
  20. app-misc/ca-certificates
  21. >=net-libs/gnutls-3:=[${MULTILIB_USEDEP}] )
  22. "
  23. DEPEND="${RDEPEND}
  24. >=sys-devel/gettext-0.19.4
  25. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
  26. test? ( sys-apps/dbus[X] )
  27. "
  28. # eautoreconf needs >=sys-devel/autoconf-2.65:2.5
  29. multilib_src_configure() {
  30. ECONF_SOURCE=${S} \
  31. gnome2_src_configure \
  32. --disable-static \
  33. --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
  34. $(use_with gnome gnome-proxy) \
  35. $(use_with libproxy) \
  36. $(use_with smartcard pkcs11) \
  37. $(use_with ssl gnutls)
  38. }
  39. multilib_src_test() {
  40. # XXX: non-native tests fail if glib-networking is already installed.
  41. # have no idea what's wrong. would appreciate some help.
  42. multilib_is_native_abi || return 0
  43. virtx emake check
  44. }
  45. multilib_src_install() {
  46. gnome2_src_install
  47. }
  48. pkg_postinst() {
  49. gnome2_pkg_postinst
  50. multilib_pkg_postinst() {
  51. gnome2_giomodule_cache_update \
  52. || die "Update GIO modules cache failed (for ${ABI})"
  53. }
  54. multilib_foreach_abi multilib_pkg_postinst
  55. }
  56. pkg_postrm() {
  57. gnome2_pkg_postrm
  58. multilib_pkg_postrm() {
  59. gnome2_giomodule_cache_update \
  60. || die "Update GIO modules cache failed (for ${ABI})"
  61. }
  62. multilib_foreach_abi multilib_pkg_postrm
  63. }