gssdp-1.0.2.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. VALA_USE_DEPEND="vapigen"
  5. inherit gnome2 multilib-minimal vala
  6. DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP"
  7. HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
  8. LICENSE="LGPL-2"
  9. SLOT="0/3"
  10. KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ppc64 ~sparc x86 ~x86-fbsd"
  11. IUSE="+introspection gtk"
  12. RDEPEND="
  13. >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
  14. >=net-libs/libsoup-2.44.2:2.4[${MULTILIB_USEDEP},introspection?]
  15. gtk? ( >=x11-libs/gtk+-3.0:3 )
  16. introspection? (
  17. $(vala_depend)
  18. >=dev-libs/gobject-introspection-1.36:= )
  19. !<net-libs/gupnp-vala-0.10.3
  20. "
  21. DEPEND="${RDEPEND}
  22. >=dev-util/gtk-doc-am-1.14
  23. sys-devel/gettext
  24. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
  25. "
  26. src_prepare() {
  27. # Disable functional test as it requires port that might be used by rygel to
  28. # be free of use
  29. sed 's/\(check_PROGRAMS.*\)test-functional$(EXEEXT)/\1/' \
  30. -i "${S}"/tests/Makefile.in || die
  31. use introspection && vala_src_prepare
  32. gnome2_src_prepare
  33. }
  34. multilib_src_configure() {
  35. ECONF_SOURCE=${S} \
  36. gnome2_src_configure \
  37. $(multilib_native_use_enable introspection) \
  38. $(multilib_native_use_with gtk) \
  39. --disable-static
  40. if multilib_is_native_abi; then
  41. # fix gtk-doc
  42. ln -s "${S}"/doc/html doc/html || die
  43. fi
  44. }
  45. multilib_src_install() {
  46. gnome2_src_install
  47. }