libgfbgraph-0.2.3.ebuild 917 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME_ORG_MODULE="gfbgraph"
  6. inherit gnome2
  7. DESCRIPTION="A GObject library for Facebook Graph API"
  8. HOMEPAGE="https://git.gnome.org/browse/libgfbgraph/"
  9. LICENSE="LGPL-2.1+"
  10. SLOT="0.2"
  11. KEYWORDS="amd64 x86"
  12. IUSE="+introspection"
  13. RDEPEND="
  14. dev-libs/glib:2
  15. dev-libs/json-glib
  16. net-libs/libsoup:2.4
  17. net-libs/gnome-online-accounts
  18. net-libs/rest:0.7
  19. introspection? ( >=dev-libs/gobject-introspection-1.30:= )
  20. "
  21. DEPEND="${RDEPEND}
  22. >=dev-util/gtk-doc-am-1.14
  23. virtual/pkgconfig
  24. "
  25. # FIXME: most tests seem to fail
  26. RESTRICT="test"
  27. src_configure() {
  28. gnome2_src_configure --disable-static
  29. }
  30. src_install() {
  31. gnome2_src_install
  32. # Remove files installed in the wrong place
  33. # Also, already done by portage
  34. # https://bugzilla.gnome.org/show_bug.cgi?id=752581
  35. rm -rf "${ED}"/usr/doc
  36. }