libhtp-0.5.22.ebuild 802 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit autotools multilib-minimal
  5. DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
  6. HOMEPAGE="https://github.com/OISF/libhtp"
  7. SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
  11. IUSE="debug static-libs"
  12. RDEPEND="sys-libs/zlib[static-libs?]"
  13. DEPEND="${RDEPEND}"
  14. src_prepare() {
  15. eautoreconf
  16. }
  17. multilib_src_configure() {
  18. # The debug configure logic is broken.
  19. ECONF_SOURCE=${S} \
  20. econf \
  21. $(usex debug '--enable-debug' '') \
  22. $(use_enable static-libs static)
  23. }
  24. multilib_src_install_all() {
  25. use static-libs || find "${ED}" -name '*.la' -delete
  26. }