libisds-9999.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. [[ ${PV} = 9999* ]] && inherit git-r3 autotools
  5. DESCRIPTION="Client library for accessing ISDS Soap services"
  6. HOMEPAGE="http://xpisar.wz.cz/libisds/"
  7. if [[ ${PV} = 9999* ]]; then
  8. EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
  9. else
  10. SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.xz"
  11. KEYWORDS="~amd64 ~mips ~x86"
  12. fi
  13. LICENSE="LGPL-3"
  14. SLOT="0"
  15. IUSE="+curl debug nls static-libs test"
  16. COMMON_DEPEND="
  17. app-crypt/gpgme
  18. dev-libs/expat
  19. dev-libs/libgcrypt:0=
  20. dev-libs/libxml2
  21. curl? ( net-misc/curl[ssl] )
  22. "
  23. DEPEND="${COMMON_DEPEND}
  24. virtual/pkgconfig
  25. nls? ( sys-devel/gettext )
  26. "
  27. RDEPEND="${COMMON_DEPEND}
  28. >=app-crypt/gnupg-2
  29. "
  30. DOCS=( NEWS README AUTHORS ChangeLog )
  31. src_prepare() {
  32. default
  33. [[ ${PV} = 9999* ]] && eautoreconf
  34. }
  35. src_configure() {
  36. local myeconfargs=(
  37. --disable-fatalwarnings
  38. $(use_with curl libcurl)
  39. $(use_enable curl curlreauthorizationbug)
  40. $(use_enable debug)
  41. $(use_enable nls)
  42. $(use_enable static-libs static)
  43. $(use_enable test)
  44. )
  45. econf "${myeconfargs[@]}"
  46. }
  47. src_install() {
  48. default
  49. find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
  50. }