libmbim-1.14.0.ebuild 783 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit multilib
  5. DESCRIPTION="Mobile Broadband Interface Model (MBIM) modem protocol helper library"
  6. HOMEPAGE="https://cgit.freedesktop.org/libmbim/"
  7. SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
  8. LICENSE="LGPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 arm ~mips ppc ppc64 x86"
  11. IUSE="static-libs udev"
  12. RDEPEND=">=dev-libs/glib-2.32:2
  13. udev? ( virtual/libgudev:= )"
  14. DEPEND="${RDEPEND}
  15. dev-util/gtk-doc-am
  16. virtual/pkgconfig"
  17. src_configure() {
  18. econf \
  19. --disable-more-warnings \
  20. --disable-gtk-doc \
  21. $(use_with udev) \
  22. $(use_enable static{-libs,})
  23. }
  24. src_install() {
  25. default
  26. use static-libs || rm -f "${ED}/usr/$(get_libdir)/${PN}-glib.la"
  27. }