libnfsidmap-0.25.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit autotools eutils multilib
  5. DESCRIPTION="NFSv4 ID <-> name mapping library"
  6. HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
  7. SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
  11. IUSE="ldap static-libs"
  12. DEPEND="ldap? ( net-nds/openldap )"
  13. RDEPEND="${DEPEND}
  14. !<net-fs/nfs-utils-1.2.2
  15. !net-fs/idmapd"
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${PN}-0.19-getgrouplist.patch #169909
  18. epatch "${FILESDIR}"/${PN}-0.21-headers.patch
  19. eautoreconf
  20. }
  21. src_configure() {
  22. econf \
  23. --disable-dependency-tracking \
  24. $(use_enable static-libs static) \
  25. $(use_enable ldap)
  26. }
  27. src_install() {
  28. default
  29. insinto /etc
  30. doins idmapd.conf
  31. # remove useless files
  32. rm -f "${D}"/usr/$(get_libdir)/libnfsidmap/*.{a,la}
  33. use static-libs || find "${D}"/usr -name '*.la' -delete
  34. }