libsmi-0.5.0.ebuild 872 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="A Library to Access SMI MIB Information"
  6. HOMEPAGE="http://www.ibr.cs.tu-bs.de/projects/libsmi"
  7. SRC_URI="${HOMEPAGE}/download/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
  11. IUSE="static-libs"
  12. src_configure() {
  13. econf $(use_enable static-libs static)
  14. }
  15. src_test() {
  16. # sming test is known to fail and some other fail if LC_ALL!=C:
  17. # http://mail.ibr.cs.tu-bs.de/pipermail/libsmi/2008-March/001014.html
  18. sed -i '/^[[:space:]]*smidump-sming.test \\$/d' test/Makefile
  19. LC_ALL=C emake -j1 check || die
  20. }
  21. src_install () {
  22. default
  23. dodoc smi.conf-example ANNOUNCE ChangeLog README THANKS TODO \
  24. doc/{*.txt,smi.dia,smi.dtd,smi.xsd}
  25. prune_libtool_files
  26. }